Tools
Rss Categories

Role Management must be used to install .NET 3.5

Views: 822 Created: 2016-08-04 12:15 Last Updated: 2016-08-11 12:31

SYMPTOM

The following error message displays while attempting to install Yearli:

“You must use the Role Management Tool to install or configure Microsoft .NET Framework 3.5 SP1”.

CAUSE

Currently on Windows Server 2008 R2, .NET Framework 3.5 SP1 comes as a feature in Server Manager. Since this is a feature of the operating system, Windows does not allow installation during normal program installation. This feature must be installed separate from the program.

RESOLUTION

Procedure 1 (Download the corresponding installation file)

  1. Click the Start menu.
  2. Click All Programs.
  3. Highlight Administrative Tools and select Server Manager.
  4. In the Server Manager Interface, click Features.
  5. Select Add Features to display a list of possible features.
  6. In the Select Features interface, expand .NET Framework 3.5.1 Features.
  7. Check the box next to .NET Framework 3.5.1 and click Next.
  8. In the Confirm Installation Selections interface, review the selections and then click Install.
  9. Allow the installation process to complete and then click Close.

APPLIES TO

  • Windows Server 2008
  • WinFiler 2012 - 2013
  • WinFiler Plus 2013
  • Yearli 2014 - Current